Dynamics GP hangs after installing for the first time or upgrading to a newer build.

Issue:
After the installation process completes for Dynamics GP Toolbox, you notice that Dynamics GP hangs during the initialization message when launching for the first time after an initial install or when upgrading to a newer build, which may look like the one below.  This may result in you ending/killing the task via the Task Manager.

Possible Causes:
If both Auditor and Dynamics GP Toolbox are installed, Auditor can sometimes attempt to override the Dynamics GP Toolbox Safe Login, which can result in a longer launch.

There is also sometimes be an issue, which is not Rockton Software related, that can cause Dexterity to become ‘confused’ when a user is clicking on other windows, messages, etc., during the initialization.  Basically, Dex doesn’t know which window, etc., to focus on or look at, so it can cause the initialization to take much longer.

Resolution:
Here are a few different things to try:

  1. Double-check that you are on the newest build of Auditor. There have been changes made to Auditor so that it handles the initialization of Dynamics GP better when Dynamics GP Toolbox is also installed. 
  2. This issue can occur when you are interacting during the log in process.
    1. Let’s try the following:
      1. Right-click on Dynamics GP and “Run as Administrator”.
      2. Enter in the ‘sa’ credentials.
      3. Select a company.
      4. Then, press OK.
      5. As hard as it may be, refrain from clicking, moving the mouse, or doing anything. 

       

     

  3. Take a look at any other Third-Party products that you may have installed to determine if Dynamics GP is hanging on a particular ‘initialization’.

Notes:
To check the Auditor version, go to Tools | Setup | Auditor | Auditor Setup. The newest build can be downloaded from our Product Downloads page.

If you are still having issues with Dynamics GP hanging after going through the above steps, please reach out to support@rocktonsoftware.com to continue troubleshooting.  In your email, include detailed information, such as the steps you have tried, environment, and build information. 

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