Error -2147189176: Logon Failed.

Issue:

 

When printing a Crystal Report using Dynamics Report Manager on Dynamics GP 9.0, you receive the following error message:

 

Error -2147189176: Logon Failed.

 

Cause:

 

Cause 1: The path identified in the Technical Name field in the Report Maintenance window is incorrect.

 

Cause 2: Connection issue.

 

Cause 3: Reports were created on Crystal Reports version 8.5 or prior.

 

Cause 4: Increase workstation memory.

 


Resolution:

Resolution 1:

 

  1. On the workstation with the error message, go to Reports | Dynamics Report Manager | Dynamics Report Manager Explorer.
  2. Select the report and then click the Edit Report button.
  3. Click the Technical Field folder button, browse to the location of the report, select it, and then click Open.
  4. Click Save.

 

Resolution 2:

 

Note: Each of the resolutions in this section are separate.

 

  1. In the ODBC Data Source Administrator (32-bit) window on your workstation, create a System DSN for Crystal Reports using a SQL Server Driver instead of a SQL Native Client Driver. Note: This only applies to Dynamics GP 10 and previous versions.
  2. If you are running a 64-bit ODBC connection, create a System DSN using the ODBC Data Source Administrator (32-bit) window.
    1. Go to Start | Run or type Run on your Start screen.
    2. In the Run window, type C:\Windows\SysWOW64\odbcad32.exe in the Open field.
    3. Click OK.
    4. Then in the ODBC Data Source Administrator (32-bit) window, create a System DSN for your Crystal Reports. 
  3. If the Override Report Credentials option is being used in the Dynamics Report Manager Global Reports Defaults window, the Crystal Report connection needs to be created using a SQL direct connection. If the report was created using a Trusted Connection instead, it will need to be updated to use a SQL direct connections.
    1. Open the report you are working with in Crystal Reports
    2. Go to Database |Set Datasource Location
    3. Click the Properties Expansion button.
    4. If you see Trusted Connection: 1 listed under Properties, this indicates the connection was created using a Trusted Connection.
    5. To change the connection double click on Trusted Connection and change 1 to 0 so it appears as Trusted Connection: 0.
    6. Click Close.
    7. Go to Database | Verify Database to verify the database is up to date.
    8. Do Step 3d for each report that is giving the error. 
  4. Test the ODBC DSN connection to make sure it the connection is successful.
    1. Go to Start | Run or type Run on your Start screen.
    2. In the Run window, type C:\Windows\SysWOW64\odbcad32.exe in the Open field.
    3. Click OK.
    4. In the ODBC Data Source Administrator (32-bit) window, select the Crystal Report System DSN you are using, and then click Configure. 
  5. Verify the DSN Name, Username, and Password information is correct for Crystal Reports in the Dynamics Report Manager Global Reports Defaults window.
    1. If you have chosen to override the Global Report Default connection settings on the report in Dynamics Report Manager, verify the DSN settings for that specific report.
    2. Edit the report in Dynamics Report Manager and click the Connections tab.
    3. If the Override Global Connections checkbox is marked, verify the DSN Name, Username, and Password information is correct.  
  6. If the report was created using a SQL command in Crystal Reports, make sure it is pointing to the correct database.

 

Resolution 3:

 

If the reports were created on an earlier version of Crystal Reports such as Crystal Reports Version 8.5 and before, they will need to be resaved in a more recent version such as Crystal Reports 9.0 and later.

 

Resolution 4:

 

If you are using the Data Stream or Mass Reports feature and the process starts but fails before finishing, check your workstation memory. It may need to be increased to handle the quantity of reports that you are processing. Contact your IT person about increasing the Workstation memory.