Error:
After upgrading to the latest build of Dynamics Report Manager (DRM), you receive the following error when you launch Microsoft Dynamics GP (GP):
DRM Trigger did not register.
Cause:
This error indicates the setup of a launch point is incomplete and DRM is not able to register the trigger.
Resolution:
Versions 2010 and later:
- Log into GP as sa.
- Go to Microsoft Dynamics GP | Tools | Utilities | Dynamics Report Manager | Transfer Manager.
- Export a copy of the Launch Point mentioned in the error message.
- Click Export Reports.
- Select a Filename for the exported Launch Point.
- Select the Launch Point in the Objects to Transfer section.
- Click Export.
- Go to Reports | Dynamics Report Manager | Dynamics Report Manager Explorer.
- Click Launch Points.
- Select the Launch Point mentioned in the error message, and then click the Edit Launch Point button.
- Click Duplicate to have a copy of it to reference if needed.
- Verify everything is setup correctly on the duplicate. For example, see if you have a window field or button defined for a product (e.g. Manufacturing) that has not been installed on the workstation yet.
Versions 8.0 and 9.0:
- Check the Launch Points. Specifically, the Window Field or Button Launch Point, if you have any. This Launch Point type has a “Trigger Type” under the Settings tab. If this is set up wrong, it can result in a Trigger type error message. See the Notes section below for more details on how to set up a Window Field or Button Launch Point.
- Also, verify you are upgrading to the latest build of DRM (part 2 of 2 of the downloads) and also that you have the latest DRM Launcher (part 1 of 2, of the downloads) installed. The Product Downloads can be found here: https://www.rocktonsoftware.com/gp/resources/product-downloads.
Notes:
The steps here describe how to set up a Window Field or Button Launch Point:
The Window Field or Button Launch Point provides a trigger point, usually from a button on a window, from which to launch a report from. The print button on a window is a common example, but you can launch a report from a Posting button or when a user enters a dollar amount in a specific field.
Versions 10.0 and later:
- Log into Microsoft Dynamics GP (GP) as sa.
- Go to Reports | Dynamics Report Manager | Dynamics Report Manager Explorer.
- Click Launch Points.
- Click the Add Launch Point button.
- Click Enter Manually, select Window Field or Button for the Launch Point Type, and then click OK.
- Under the Settings tab select the following:
- Trigger Type
- Attach Type
- Product, Series, and a Form
- Window and/or Field – These fields will be available based on the selection(s) in step 5c.
- Under the Reports tab, select the report(s) you would like to print.
- Use the Access tab to setup security restrictions.
- Use the Actions tab to add additional actions such as, Set Parameter to Field, Launch All Reports, etc.
Versions 8.0 and 9.0
- Log into Great Plains as a DRM Report Administrator.
- Under the Administrator View in DRM, select Launch Points.
- Click New Launch Point.
- Select Window Field or Button as the Launch Point Type, enter a New Launch Point ID, and then click OK.
- Under the Settings tab select the following:
- Trigger Type
- Attach Type
- Product, Series, and a Form
- Window and/or Field – These fields will be available based on the selection(s) in step 5c.
- Under the Reports tab, select the report you would like to print.
- Use the Access tab to setup security restrictions.
- Use the Actions tab to add additional actions such as, Set Parameter to Field, Launch All Reports, etc.
Example:
The following is an example of how to add a Customer List report to the Customer Maintenance window. Step 5 in this example is optional. It has been included in the example to display how to set a parameter in a Launch Point.
- Click on New Launch Point
- Method: Enter Manually
- Launch Point Type = Window Field or Button
- New Launch Point ID = Cust Report Button
- Settings tab:
- Trigger Type = Window Print Menu
- Attach Type = Before original Script
- Product = Great Plains
- Series = Sales
- Form = Customer Maintenance
- Window = Customer Maintenance
- Field = N/A
- Reports tab:
- Click (+) and browse to my Customer List and click Select
- Access tab: accept defaults
- Actions tab:
- Click (+)
- Action = Set Parameter to Field
- Report = Customer List
- Parameter = Customer ID
- Product = Microsoft Dynamics GP or Great Plains
- Series = Sales
- Form = Customer Maintenance
- Window = Customer Maintenance
- Field = Customer Number
- Click (+)
- Action = Launch Specific Report
- Report = Customer List