Locked Users table is missing. This may indicate that the system has been tampered with. Contact the system administrator.

Error

Locked Users table is missing. This may indicate that the system has been tampered with. Contact the system administrator.

Cause

This error can occur if you are using the User Lockout tool and the path for the Locked Users table location does not contain the RSTBUL1.dat and RSTBUL1.idx tables anymore.

Note on Web Client: We have discussed this issue with Microsoft and they have recommended that customers not have the regular desktop client and web client installed on the same machine as it is not possible to reliably run in an environment where you have both installed on the same machine. Doing so causes problems updating the Dex.ini from the desktop client.

Resolution

Option 1

If you are on GP2013 or later, it could be related to the Microsoft Dynamics GP (GP) web client.

  1. On a machine receiving the error, find and open the Dex.ini file. The Dex.ini file’s usual path is C:\Program Files (x86)\Microsoft Dynamics\GP2015\Data.
  2. Look for the following lines. If you do not see them, go to Resolution 2.

EnablePerUserIni=TRUE
WebConfigure=TRUE

  1. If these two lines exist and are set to TRUE on the Desktop Client, this is the cause of the issue. For example, when you install Dynamics GP Toolbox, these lines prevent your Dex.ini file from being updated with the necessary lines for Dynamics GP Toolbox. In order for ISV products to write to the Dex.ini file, these lines would need to be set to FALSE.Note: If you do not intend to use the web client but it was inadvertently installed, you can go to Windows | Programs and Features and remove the Web Client Runtime. Then make sure these two lines in the Dex.ini are set to equal FALSE.

Option 2

If you do not find the two lines in the Dex.ini file from Step 2 above, the next thing would be to look at the tables within GP and verify the path is valid.

  1. If you are currently receiving the error when trying to log in, follow these steps as they will allow you to log in one time as sa:
    1. Go to the Resources folder of the Dynamics GP Toolbox install file.
    2. Find the Toolbox.cnk file, copy it, and then paste it into the GP code folder.
    3. Right click on GP, click Run as Administrator, and then log in as sa.
    4. Go to Microsoft Dynamics GP | Tools | Setup | Dynamics GP Toolbox | System Settings.
    5. Double click User Lockout.
    6. Disable User Lockout by unmarking the Enable User Lockout checkbox.
    7. Click OK.
    8. Log out of GP and then log back in.
  2. If you are able to log in successfully, go to step 6.
  3. If you still cannot log into GP, verify the RSTB_LocksPath= value in the Dex.ini file. This setting needs to have the correct value in order for the login to be considered valid.
    1. Double click the Dex.ini file to open it. Note: The typical path for the Dex.ini file is C:\Program Files (x86)\Microsoft Dynamics\GP2015\Data.
    2. Verify the value for the RSTB_LocksPath= path is a valid path.
    3. Try logging back into GP.
  4. If you are able to log in successfully, go to step 6.
  5. If you still cannot log into GP, try updating the RSTB001 table to disable the User Lockout tool:
    1. In Microsoft SQL Server Management Studio run the following script in a new query against the DYNAMICS database:
      Select * from DYNAMICS..RSTB001 where RSTB_System_Setting_Key = 'LOCKOUT_Enable'
    2. If the RSTB_System_Setting_Valu is 1, update it to 0 to disable the User Lockout tool. In Microsoft SQL Server Management Studio, run the following script in a New Query against the DYNAMICS database:
      update DYNAMICS..RSTB001 set RSTB_System_Setting_Valu = 0 where RSTB_System_Setting_Key = 'LOCKOUT_Enable' 
    3. Try logging back into GP.

     

  6. If you want the User Lockout tool enabled again, follow these steps:
    1. Go to Microsoft Dynamics GP | Tools | Setup | Dynamics GP Toolbox | System Settings.
    2. Double click User Lockout.
    3. Enable User Lockout by marking the Enable User Lockout checkbox.
    4. Then verify the path is correct and valid.
    5. Click OK.
    6. Log out of GP and then log back in.

For further assistance with removing the web client, please contact Microsoft Support.

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