Error:
When opening a report in the Dynamics Report Manager (DRM) Report Maintenance window, you receive the following error message:
Path is not a valid pathname.
Causes:
Cause 1:
The Crystal Reports do not have an ODBC connection. Instead they have a SQL Server connection.
Cause 2:
The pathname has special characters in it. For example: C:\Reports (Crystal Reports)\Sales Invoice #3.rpt.
Cause 3:
The user does not have access to the location where the report file is saved.
Resolutions:
Resolution 1:
- Make a copy of the Crystal Report as a backup.
- Then follow the instructions in KB: How to create a new ODBC Data Source and then Set Database Location in Crystal Reports.
Resolution 2:
Remove the special characters in the path.
- Review the path to the report and the report file name.
- Rename the folders that contain special characters. If the folder and report file names have special characters, rename them similar to the following:
- Folder name: Reports Crystal Reports
- File name: Sales Invoice 3.rpt
Resolution 3:
Change the folder permissions for the file location by following one of the steps below.
- Give the user permission to the folder where the file is located.
- Change the file location to a folder where the user has permission.