The stored procedure syUserInRole returned the following results: DMBS: 911, Microsoft Dynamics GP: 0

Error:

You receive the following error message when you close windows after trying to set up a new audit.

The stored procedure syUserInRole returned the following results: DMBS: 911, Microsoft Dynamics GP: 0.

Causes:

Cause 1: A record is stranded. (See Resolution 1)

Cause 2: Invalid data. (See Resolution 2)

Resolutions:

Resolution 1:

  1. Log out of the system and make a complete restorable backup.
  2. Go to Microsoft Dynamics GP | Tools | Setup | Auditor | Auditor Setup.
  3. Click the Setup tab.
  4. Click Reconcile.
  5. Mark Remove stranded items.
  6. Click Process.

Resolution 2:

  1. Have everyone log out of the system and make a complete restorable backup.
  2. Go to Microsoft Dynamics GP | Tools | Setup | Auditor | Auditor Setup.
  3. Click the Troubleshooting tab.
  4. Mark Rebuild SQL Tables Master.
  5. Click Process.