Locked Users Table is Missing error in Dynamics GP 9.0 or Dynamics GP 10.0

Error:

When you try to log into Dynamics GP, you receive the following error message:

Locked Users Table is Missing

Cause:

This issue has been documented as a software bug.

Resolution:

This issue has been resolved in Omni Price for Microsoft Dynamics GP 9.0 (build 6), Omni Price for Microsoft Dynamics GP 10.0 (build 12), and later builds.

Resolution 1:

Download and install the latest build. To do this, follow the steps in Knowledge Base article: Installing a Rockton Software product: First install or installing the latest build/newest version (https://www.rocktonsoftware.com/gp/resources/knowledge-base-item/lists/kb_allproducts/installing-the-latest-build-newest-version).

Resolution 2:

If Resolution 1 is not an option, the workaround is as follows:

  1. Copy the Omni Tools .cnk file from where you have it saved and paste it into the GP Application folder. The typical location of the Dynamics GP Application folder is: C:\Program Files (x86)\Microsoft Dynamics\GP. 
  2. Log into Dynamics GP as sa or DYNSA. If you are able to log into Dynamics GP successfully, go to Step 3; otherwise, try the following:
    1. Go to your Dynamics GP Application folder.
    2. Find the Dex.ini file and make a copy of it.
    3. Open the Dex.ini file, delete the WDC_Auto_Login line, and then save the changes.
    4. Log into Dynamics GP. 
  3. Go to Tools | Setup | Omni Tools | Omni Password, mark the Lockout users after three failed password attempts checkbox. 
  4. In the Options window under Locked Users table location where you entered the UNC path name, add a backslash character (\) to the end of the path if one does not already exist, and then tab off the field. 

    Note: This is the pathname of the table that stores the Users that have been locked out. This table is a Ctree table, not a SQL table.  For example, instead of creating the table on the SQL Server with the other tables in the system, Omni Tools will create two files called RSOT001.dat and RSOT001.idx in the location you enter here.

    We recommend that it be a UNC pathname because if it is just a mapped drive, then every User would have to have that very same drive letter mapped exactly the same way in order for it to work. UNC doesn’t require a drive letter. 

  5. Click OK.
  6. Click OK.