Issue:
After installing Omni Price in some but not all of your companies, when attempting to log into a company that does not have Omni Price installed in it, you receive the following error message:
A get/change operation on table ‘WDC_Pricing_SETP’ failed accessing SQL data.
Invalid object name ‘WDC42100’.
Cause:
This situation has been documented as a software bug. The error message appears when logging into a company that does not have Omni Price installed in it but another company has Omni Price installed in it.
Workaround:
Option 1: Install Omni Price in all companies. Then do the following in the companies where you want Omni Price inactive:
- Go to Microsoft Dynamics GP | Tools | Setup | Omni Price | Pricing Setup.
- Unmark Activate Customer Pricing System.
- Click OK.
Option 2: Use a separate Dynamics.set file logging into the companies where Omni Price is not installed. Here is an example of how to modify the Dynamics.set file:
- Reduce the top number by 1.
- Remove the following lines. Please note that the path is an example of the default path used for GP 2016.Your path may be different.
- 1999
- Omni Price
- :C:Program Files (x86)/Microsoft Dynamics/GP2016/OMNIPRCE.DIC
- :C:Program Files (x86)/Microsoft Dynamics/GP2016/Data/OPRC_FRM.DIC
- :C:Program Files (x86)/Microsoft Dynamics/GP2016/Data/OPRC_RPT.DIC
Note:
To have your contact information added to the bug so that you are notified with any updates regarding the bug, please reach out to support@rocktonsoftware.com.