Omni Price Pricing Transaction is not created for the Invoice when transferring an Order to an Invoice in Sales Order Processing

Issue:

When transferring an Order in Sales Order Processing to an Invoice, the Invoice Pricing Transaction record is not created in Omni Price. (Go to Inquiry | Omni Price | Pricing Transactions.)

You may also see the following message during the Sales Order Processing Transfer process:

Rockton Omni Price error 17 occurred in script RSOP_AFTER_SOPEntry_Get_Number.

Cause:

Dynamics GP Toolbox DocSync tool is enabled and the Omni Price Product is listed above the Dynamics GP Toolbox Product in the Dynamics.set file.

Resolutions:

    Resolution 1:

    If DocSync should be enabled, find and edit all of the Dynamics.set files on the workstations that both Dynamics GP Toolbox and Omni Price are installed on.

    1. The typical path is: C:\Program Files (x86)\Microsoft Dynamics\GP2016.
    2. Once you find the file, right click on it, and then click Edit.
    3. In the top part of the file, here is an example of what it should look like:

      24

      0

      Microsoft Dynamics GP

      6443

      Dynamics GP Toolbox

      1999

      Omni Price

      Note: The rest of the 21 products would be listed in the top part of the Dynamics.set file as well. The key is that the Dynamics GP Toolbox two product lines must be located above the Omni Price two product lines.

    4. In the bottom part of the file, here is an example of what it should look like:

      Windows

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/Dynamics.dic

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/Data/FORMS.DIC

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/Data/REPORTS.DIC

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/TOOLBOX.DIC

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/Data/FRMS6443.DIC

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/Data/RPTS6443.DIC

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/OMNIPRCE.DIC

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/Data/OPRC_FRM.DIC

      :C:Program Files (x86)/Microsoft Dynamics/GP2016/Data/OPRC_RPT.DIC

      Note: The rest of the 21 products would be listed in the bottom part of the Dynamics.set file as well. The key is that the Dynamics GP Toolbox three product lines must be located above the Omni Price three product lines.

    Resolution 2:

    If DocSync should be disabled meaning you are not using it, please do the following:
       

    1. Go to Microsoft Dynamics GP | Tools | Setup | Dynamics GP Toolbox | System Settings.
    2. Double click on DocSync.
    3. Unmark the Enable DocSync checkbox, and then click OK.