Issue
Rockton Pricing Management (RPM) is not calculating prices or is calculating incorrect prices.
Causes
- The ERP does not have the “Enable Rockton Pricing Management” check box marked.
- The Price Schedule is not active.
- Pricing Mode is incorrect.
- A Price Filter is limiting results.
- Price Schedule does not match existing Price Level or Price Class.
- Price Schedule has an incorrect Rank.
- The Price Calculation is configured incorrectly.
Resolution
Resolution 1
Enable RPM within the ERP system you are using.
Acumatica
- Log in to Acumatica as a User with access to the RPM Settings screen.
- Go to Configuration | Common Settings | RPM Settings.
- Mark the Enable Rockton Pricing Management check box.
Dynamics GP
- Log in to Dynamics GP as a User with access to the RPM Company window.
- Go to Microsoft Dynamics GP | Tools | Setup | Rockton Pricing Management | Company Setup or use the RPM shortcut from the Taskbar.
- Mark the Enable Rockton Pricing Management for this Company check box.
Resolution 2
Mark the Price Schedule as Active.
- Log in to the RPM web application.
- Expand the Pricing menu and click Price Schedules.
- Open the Price Schedule the transaction should use.
- Mark the Is Active check box.
Resolution 3
Verify the Pricing Mode in use. If using Dynamic pricing, ensure that the Price Schedule in RPM has “Use in Dynamic Pricing” marked.
Acumatica
- Log in to Acumatica as a User with access to the RPM Settings screen.
- Go to Configuration | Common Settings | RPM Settings.
- Verify the Pricing Mode selected. If Pricing Mode is Dynamic, continue with steps 4-6 below.
- Log into the RPM web application.
- Expand the Pricing menu and click Price Schedules.
- Lastly, mark the Use in Dynamic Pricing check box for at least one Price Schedule.
Dynamics GP
- Log in to Dynamics GP as a User with access to the RPM Company window.
- Go to Microsoft Dynamics GP | Tools | Setup | Rockton Pricing Management | Company Setup or use the RPM shortcut from the Taskbar.
- Verify the Pricing Mode selected. If Pricing Mode is Dynamic, continue with steps 4-6 below.
Resolution 4
Check Price Schedule and Price Calculations for Pricing Filters limiting the pricing results.
- Log into the RPM web application.
- Expand the Pricing menu and click Price Schedules.
- Check the Pricing Filter column and check for any Pricing Filters that may be limiting the results.
- From the Pricing menu, click Price Calculations.
- Check the Pricing Filter column for any filters that could be limiting.
Resolution 5
The Price Schedule in the RPM engine must match a Price Level (Dynamics GP) or Customer Price Class (Acumatica).
- Log into the RPM web application.
- Expand the Pricing menu and click Price Schedules.
- Verify the Price Schedules are also in the ERP.
Acumatica – Receivables | Preferences | Customer Price Class
Dynamics GP – Microsoft Dynamics GP | Tools | Setup | Inventory | Price Level
Resolution 6
When multiple Price Schedules are found for the pricing scenario, and one of them has a higher rank than the others, it is essential to examine the ranks assigned.
- In RPM, expand the Pricing menu.
- Click Price Schedules.
- Check the Dynamic Pricing Rank column for the ranks.
Resolution 7
The Price Calculation is set up incorrectly.
- Check whether the Amount/Percent field is set as a positive or negative correctly.
- View the Modify Unit Price check box and mark is needed.
- Determine if the From Base Price is properly marked.
- Mark to track to GL if not set to track GL Accounts.
For more detailed information on issues with Price Calculations see KB Article: Price Calculations are not Calculating as Expected.