RPM is not Calculating the Correct Price

Issue

Rockton Pricing Management (RPM) is not calculating prices or is calculating incorrect prices.

Causes

  1. The ERP does not have the “Enable Rockton Pricing Management” check box marked.
  2. The Price Schedule is not active.
  3. Pricing Mode is incorrect.
  4. A Price Filter is limiting results.
  5. Price Schedule does not match existing Price Level or Price Class.
  6. Price Schedule has an incorrect Rank.
  7. The Price Calculation is configured incorrectly.

Resolution

Resolution 1

Enable RPM within the ERP system you are using.

Acumatica
  1. Log in to Acumatica as a User with access to the RPM Settings screen.
  2. Go to Configuration | Common Settings | RPM Settings.
  3. Mark the Enable Rockton Pricing Management check box.

Dynamics GP
  1. Log in to Dynamics GP as a User with access to the RPM Company window.
  2. Go to Microsoft Dynamics GP | Tools | Setup | Rockton Pricing Management | Company Setup or use the RPM shortcut from the Taskbar.
  3. Mark the Enable Rockton Pricing Management for this Company check box.

Resolution 2

Mark the Price Schedule as Active.

  1. Log in to the RPM web application.
  2. Expand the Pricing menu and click Price Schedules.
  3. Open the Price Schedule the transaction should use.
  4. Mark the Is Active check box.

Resolution 3

Verify the Pricing Mode in use. If using Dynamic pricing, ensure that the Price Schedule in RPM has “Use in Dynamic Pricing” marked.

Acumatica
  1. Log in to Acumatica as a User with access to the RPM Settings screen.
  2. Go to Configuration | Common Settings | RPM Settings.
  3. Verify the Pricing Mode selected. If Pricing Mode is Dynamic, continue with steps 4-6 below.

  1. Log into the RPM web application.
  2. Expand the Pricing menu and click Price Schedules.
  3. Lastly, mark the Use in Dynamic Pricing check box for at least one Price Schedule.
Dynamics GP
  1. Log in to Dynamics GP as a User with access to the RPM Company window.
  2. Go to Microsoft Dynamics GP | Tools | Setup | Rockton Pricing Management | Company Setup or use the RPM shortcut from the Taskbar.
  3. Verify the Pricing Mode selected. If Pricing Mode is Dynamic, continue with steps 4-6 below.

Resolution 4

Check Price Schedule and Price Calculations for Pricing Filters limiting the pricing results.

  1. Log into the RPM web application.
  2. Expand the Pricing menu and click Price Schedules.
  3. Check the Pricing Filter column and check for any Pricing Filters that may be limiting the results.

  1. From the Pricing menu, click Price Calculations.
  2. Check the Pricing Filter column for any filters that could be limiting.

Resolution 5

The Price Schedule in the RPM engine must match a Price Level (Dynamics GP) or Customer Price Class (Acumatica).

  1. Log into the RPM web application.
  2. Expand the Pricing menu and click Price Schedules.
  3. Verify the Price Schedules are also in the ERP.

Acumatica – Receivables | Preferences | Customer Price Class

Dynamics GP – Microsoft Dynamics GP | Tools | Setup | Inventory | Price Level

Resolution 6

When multiple Price Schedules are found for the pricing scenario, and one of them has a higher rank than the others, it is essential to examine the ranks assigned.

  1. In RPM, expand the Pricing menu.
  2. Click Price Schedules.
  3. Check the Dynamic Pricing Rank column for the ranks.

Resolution 7

The Price Calculation is set up incorrectly.

  1. Check whether the Amount/Percent field is set as a positive or negative correctly.
  2. View the Modify Unit Price check box and mark is needed.
  3. Determine if the From Base Price is properly marked.
  4. Mark to track to GL if not set to track GL Accounts.

For more detailed information on issues with Price Calculations see KB Article: Price Calculations are not Calculating as Expected.