System Lockout is locking out ‘sa’ even though they are an excluded user

Issue:
After enabling the System Lockout tool, ‘sa’ is unable to log in to GP. They have been marked as an Excluded User.

Cause:
The ‘sa’ user is not part of an Excluded group. As of the following builds, you need to set up a User Group for the tool and not just the individual user.

GP10 – build 10.0.17
GP2010 – build 11.0.16
GP2013 – build 12.0.3
GP2015 and above

Resolution:
After disabling the System Lockout feature, create a group for your Administrators and then add the specified users to the Excluded Group. Then enable the System Lockout feature.

1. Make a complete restorable backup of Microsoft Dynamics GP.
2. Open SQL Server Management Studio and connect to the server that Microsoft Dynamics GP resides on.
3. Click New Query.
4. Run the following statement to disable the System Lockout tool:

update DYNAMICS..RSTB001 set RSTB_System_Setting_Valu = '0' where RSTB_System_Setting_Key = 'SYSLOCK_ENABLE'

5. Log into Microsoft Dynamics GP as sa or an Administrator.
6. On the Microsoft Dynamics GP menu, click Tools | Dynamics GP Toolbox | User Group Setup.
7. Create a User Group ID and give it a Description.

8. From the Users list, mark the checkbox for those users you wish to exclude from the tool.

9. Click Insert and then click Save.


10. On the Microsoft Dynamics GP menu, click Tools | Dynamics GP Toolbox | System Settings and then open the System Lockout tool by double-clicking on it in the list.
11. Mark the Enable System Lockout checkbox.
12. With the tool activated, click the [+] symbol in the Settings by User Group area of the window.
13. Select the newly created User Group.

14. If you do not need the tool enabled, unmark the enable checkbox. Otherwise, click OK.

Note: It is best to also create a group for normal users that would normally be included in the System Lockout.  You would use steps 1-4, however, the User Group ID and Description should relate to normal users who are included. See the example below.