This item belongs to a class not available to the current Customer

Issue:

You receive the following message in Omni Price.

This item belongs to a class not available to the current Customer, please select another warning message.

Cause:

The SOP Item Restriction option is marked in the Control Panel but is not set up in Omni Price.

Resolutions:

Resolution 1

Disable the option if you are not going to use it.

  1. Go to Cards | Omni Price | Control Panel.
  2. Unmark the Disable Restriction of  Items by Item class under the SOP Item Restriction section.

We recommend you make this a system wide setting. If using the Omni Price Customer Pricing core module, there is functionality to only allow items which are on a contract which can provide a similar function to the SOP Item Restriction with more flexibility.

Resolution 2

If this feature is activated from the Omni Price Registration window, the items available to select in SOP will be restricted by the Item Class of the Item. This feature can be disabled using the Omni Price Control Panel discussed in the previous chapter.

This feature works as follows:

  1. Items belong to Item Classes as entered into Item Maintenance.
  2. Item Classes can be group together by having the same first letter in the Item Class ID.
  3. The User Defined 2 field of each Customer is used to define which Item Class Groups should be available to that Customer. The User Defined Field should contain the first letters of any Item Classes that the Customer can purchase.
  4. When using the Item Lookup from SOP, it will be restricted to only show Items from the specified Item Class Groups, or Items not assigned to an Item Class.
  5. When Adding an Item onto a SOP Transaction Line, it will be rejected if it belongs to an Item Class which is not one of the specified classes.