Issue:
When you try to open the Reset Batches window in Dynamics GP Toolbox, you receive the following message:
This window is already being used by sa, please try again later.
Cause:
This issue may occur because a record for the sa user is stuck in the Payroll Activity table.
Resolution:
- Make a complete restorable backup and have everyone out of the system.
- In Microsoft SQL Server Management Studio, click New Query.
- Run the following script against the DYNAMICS databases to see what record is stuck. Replace XXX with the User ID that appears in the error message. Note the DEX_ROW_ID for the stuck record.
Select * from DYNAMICS..UPR10300 where USERID = 'XXX' and PYRLACTV = 'WT_BAT'
- Run the following script against the DYNAMICS database to delete the stuck record. Replace YYY with the DEX_ROW_ID of the stuck record you noted in Step 3 above.
Delete DYNAMICS..UPR10300 where DEX_ROW_ID = YYY