Unit Price, Extended Price, and Special Unit Price Appear as a Zero Value for an Item

Issue:
For an Item with a Fixed Amount on a newly created Contract, the dollar value is appearing as zero / 0.00 or as a different number than the one defined for the following fields:

  • Unit Price and Extended Price in the Sales Transaction Entry window or the Invoice Entry window.
  • Special Unit Price in the Price Check window.

Cause:
A possible cause of this situation is having a rounding option defined on the Contract.

Resolution:
If a rounding option is the cause of the situation, follow these steps to resolve it:

  1. Make a complete restorable backup.
  2. Go to Cards | Omni Price | Contract.
  3. Select the Contract the Item is on.
  4. Click Actions, and then click Options.
  5. If Round Policy is set to a value other than None, change it to None.
  6. Click OK.
  7. Click Save.